ログイン
ユーザ名:

パスワード:



パスワード紛失

新規登録
参照元情報
参照なし

Ccenterの画像添付について

  • このフォーラムに新しいトピックを立てることはできません
  • このフォーラムではゲスト投稿が禁止されています

投稿ツリー


前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2013/7/21 1:39
pocopoco  新米   投稿数: 4
Ccenterへのご質問になりますが、よろしくお願いします。

ccneter0.98を利用させていただいています。

添付ファイルを3つ設定したくて、下記のように設定しました。

画像1,file
画像2,file
画像3,file

それで下記のような現象が出ております。

実際のフォームで表示されている3つの添付ファイル項目をすべて指定して送信すると、メールやサーバー内にurlや画像が保存されます。

ただし、画像1の添付項目、一箇所だけファイルを指定して送信すると、メール内にはno fileとなって、サーバー内にも指定した画像が保存されていません。

複数ファイルを指定する場合、上記のような現象を回避する方法ってあるでしょうか?

すみませんが、よろしくお願いします。

前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2013/7/21 11:16 | 最終変更
nobu  管理人   投稿数: 851
次のようなフォームでテストしてみましたが、問題は再現できませんでした。
お名前 *,size=40
メールアドレス *,mail,size=50
性別,radio,男性+,女性
電話番号,size=15,"check=^[-0-9,\(\)]*$",#^[-0-9,\(\)]*$
やってみたいこと*,checkbox,size=10,打楽器,ダンス,デザイン,制作,*=その他,#<br />(複数選択可)
期間,select,一日,一週間+,一ヶ月,三ヶ月,半年,一年
コメント*,textarea,cols=50,rows=5
添付ファイル1,file,size=30
添付ファイル2,file,size=30
添付ファイル3,file,size=30
内部用,hidden,内部メモ用
添付の画像を 0〜3 で試した限り問題の状態は発生しませんでした。

サーバー側は、このサイトと同じ環境です。
CentOS 5.9 i686
php-5.3.3
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2013/7/21 19:30
pocopoco  新米   投稿数: 4
nobu様、ご返事ありがとうございます。

私が利用しているサーバーは、さくらインターネットのレンタルサーバーなのですが、Freebsdでphp5.3.3になります。
テストいただいたフォーム内容を貼り付けて、こちらの環境で試してみたのですが、同じような現象が出ます。
それで、なんでだろう・・と思って、調べていたのですが、すみません。

以前、こちらでダウンロードしたCcenterを利用させていただいていると思っていたのですが、下記で紹介されていたものを使用していたようです。
www.xugj.org/modules/QandA/index.php?post_id=11487
ccenter098_fix6.zip

XOOPSのモジュール管理でバージョンが0.98だったもので、つい、こちらでダウンロードしたものと勘違いしておりました。

フォームを作成すると画像認証が自動的に設定されるので、この機能もついに付加されたんだ!と勝手に喜んでたんですが、本当に、申し訳ありません。

ただ、画像認証機能って便利で、知り合いの方のサイトは、画像認証をつけた後は、まったく無いとは言えませんが、ほぼジャンクメールでの問い合わせはなくなったということで、ある程度、抑止力にはなっているのかと思っております。

今回のは、ccenter098_fix6.zipでの現象かもしれませんが、こちらの本家CCENTERでの画像認証の組み込みっていうものは、お考え無いでしょうか。

クレクレ君になって申し訳ないですが、対応していただけると、運用上の利便性が向上するかと思っております。

勝手なお願いですみません。
  条件検索へ

© 2008 MySite Web Service